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3D Image Coregistration 
 

1. Introduction 
This Quick Start guide describes FireVoxel’s tools for image registration in the main menu’s Register 

group, illustrated by different scenarios:  

1) Coregister using Orientation\Position tags – MRI to MRI acquired in the same subject in the 

same imaging session; 

2) Coregister using Mutual Information with AutoFocus – CT to MRI;  

3) Landmark registration – ultrasound to MRI.  

Users will need to select the tools that are best suited for their images, required registration accuracy, 

computational resources, and processing time.  

During registration, one image (source) is transformed and aligned with another image (target) that 

remains unchanged. The resulting coregistered image has the same resolution as the target image. This 

naming convention will be followed throughout this document.  

2. Coregister with DICOM tags 
FireVoxel’s basic coregistration command – Register > Coregister Using Orientation\Position tags – uses 

the orientation and positon information extracted from the DICOM headers. This method works best for 

images acquired during the same imaging session. The patient position is assumed to be unchanged 

between the two acquisitions. The source and target images may have different resolution and imaging 

orientation. In addition to DICOM, this command may work for NIfTI images that unambiguously store 

the image orientation information. This method is fast and requires no parameters to be adjusted.  

Steps:  

1) Open the source image in FireVoxel. If the images are stored in DICOM format, use File > Open 

DICOM folder: Single document. The DICOM Tree dialog will be displayed (Fig. 1). Select the 

needed series and click Load. The source image will be displayed in a new document window. 

2) Alternatively, if the images were previously saved as a FireVoxel document, use File > Open 

FireVoxel document. If images are stored in NIfTI format (*.nii, *.nia) or another image format, 

load images using File > Open Image. 

3) Open Layer Control by double-clicking on the image. If the source document contains multiple 

layers, including ROIs, make sure that the base layer (acquired image, MRI, CT, PET, etc.) is the 

active layer (indicated by the red outline around the layer name). Keep Layer Control open. 
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4) Now open the target image in another document window (Fig. 2). Make sure that the target 

window is the active window by clicking on it. The Layer Control will display the layers in the 

active window. The active window is indicated by the blue title bar at the top of the window. 

Also make sure that the base image is the active layer. 

5) Select Register > Using Orientation\Position tags on the main menu.  

Fig. 1. Images loaded using File > Open DICOM folder: Single document. The command 
opens DICOM Tree dialog displaying images in the selected folder (T1-weighted 
MPRAGE). 

Fig. 2. Images for coregistration using DICOM tags. Left: Target image (T2-weighted, active 
window). Right: Source image (T1-weighted (active layer) and segmentation mask (ROI 
layer)). The Layer Control panel shows the layer content in the active window (left, target). 
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6) A dialog opens with the output options (Fig. 3). Select an option to start processing or cancel:  

a. Add as a new layer – Coregistered image will be added to the target window as a new 

(topmost) layer;  

b. Create new Document – Coregistered image will be displayed in a new document 

window;  

c. Cancel – Cancel the operation.  

7) When the registration is completed, the coregistered image will be displayed according to the 

selected option: (a) in a new layer or (b) in a new document window. The new layer or 

document is labeled [source]_reg (Fig. 4). All layers of the source image will be coregistered 

together and placed either into the target window or into the new document window. 

 

8) Check the accuracy of registration. Open Layer Control, use the Alpha slider to adjust the layer 

transparency to inspect the coregistered image. Displaying one of the layers as a color map 

Fig. 4. Coregistration with DICOM tags: Results for coregistered image added as a layer in 
the target window. Left: Target window with 3 layers – target (T2-weighted image) and two 
coregistered layers (T1-weighted image and ROI). 

Fig. 3. Coregister with DICOM tags > Output options dialog. 
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instead of grayscale (Layer Control > View Filter > select color map) may also be helpful for 

verifying the accuracy of alignment.  

9) If coregistration accuracy is unacceptable, try a more advanced coregistration method, such as 

Register > Mutual Information with AutoFocus.  

3. Coregister Using Mutual Information with AutoFocus 
Coregistration with Register > Mutual Information with AutoFocus works for images acquired during 

different imaging sessions or even with different modalities. This method may use a target ROI enclosing 

the organ or tissue of interest to restrict coregistration and speed up processing. Coregistration can be 

performed without the target ROI, but it may take much longer than with the ROI. 

Steps:  

1) Open the source image in one document window.  

2) Open the target image in another document window.  

3) Define a rough target ROI enclosing the organ or tissue of interest. You may use manual or 

automatic segmentation tools (Fig. 5).  

a. For a manual ROI, use Layer Control > New ROI 3D to create a new ROI layer. 

Use the paintbrush tool (Ctrl+Left mouse) to draw a rough contour around the organ of 

interest. Define these contours on every few slices (e.g., on every 5th slice). Next, use ROI 

> Morphology > Fill 2D Contours and Morph Convex to fill the contours and extend the 

ROI across slices. The resulting ROI should fully enclose the organ or tissue of interest.  

 

4) Select the target window as the active window and select the base image as the active layer (Fig. 

6). Select Register > Mutual Information with AutoFocus.  

5) If the active layer is an ROI layer, a warning will be shown: Target vs ROI. Proceed? The user is 

advised to click No, select the base image as the active layer, and repeat registration command. 

6) If the active layer is the base image, a dialog window will open (3D Registration with AutoFocus, 

Fig. 7). 

Fig. 5. Target image with a rough target ROI enclosing the kidney (organ of interest), 
displayed in three orthogonal projections. 
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7) Check the Use Target ROI box (it is checked by default if an ROI is present).  

8) Select suggested AutoFocus and Finetune parameters. It is recommended to start with 

AutoFocus: Translation and Rotation only and Finetune: Transform > Rigid.  

9) Click OK to start processing. Registration will commence. Its progress will be indicated in the 

bottom right corner of the software window.  

Fig. 6. Left: Target window with the base image of the left kidney (MRI) and target ROI. 
Right: Source image (CT) of the same kidney.  

Fig. 7. 3D Registration with AutoFocus dialog with suggested settings. 
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10) When registration is completed, a new layer with coregistered image will be created in the 

target window (Fig. 8).  

11) Check registration accuracy using Layer Control > Alpha slider to adjust the transparency of the 

coregistered layer.  

12) If registration accuracy is unacceptable, repeat steps 5-9 and adjust the coregistration 

parameters one at a time on each iteration. 

4. Details on Coregistration with AutoFocus Dialog 
The coregistration algorithm searches for a transformation that best matches the source and the target 

volumes. The transformations range from simple translations to affine. The matching of the volumes is 

based on optimizing a similarity measure. The user may choose from several similarity measures, from 

simple and quick to complex and thus more computationally “costly”. The similarity measures include: 

1) Signal Difference, 2) Cross Correlation, 3) Image Ratio Uniformity, 4) Mutual Info, 5) Mutual Info 

Normalized, 6) URAL, 7) URALTAU. 

The transformation is computed in two stages, AutoFocus and fine-tuning: 

1. AutoFocus. The algorithm constructs a variety of transformations with combinations of 

parameters that span a multidimensional grid. The transformations include translation, scaling, 

rotation, and shear. By default, only translations are considered. The volume is subsampled. The 

transformations are ranked by how well they match the two volumes based on the similarity 

measure. A user-selected number of the best transformations is retained for the second, fine-

tuning stage (Power field, default: 1). 

Fig. 8. Results of Register > Mutual Information with AutoFocus operation. Right: Target MR 
image with coregistered CT image superimposed on top. 
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2. Fine-tuning. The algorithm performs iterative adjustment of the best transformation 

parameters until it finds a local optimum of the similarity measure. Finally, the transformed 

source image is interpolated and saved as a new layer in the target image window.  

The recommended strategy for achieving satisfactory coregistration is to start with the simplest settings, 

transformations, and similarity measure and progressively add more complex options one at a time to 

obtain more accurate registration results. The user may try adjusting the following options: 1) increase 

Power, 2) add rotations and other transformations, or 3) upgrade the similarity measure. 

5. Landmark Coregistration 
Another coregistration method is coregistration with landmarks. This option is the least preferable and 

should be used as a last resort. It may be used when a fully automatic process may not provide accurate 

results, for example, to coregister images acquired with different modalities, or acquired images and 

atlas maps. 

Landmark coregistration alignes two images by superimposing their landmark locations, or prominent 

sites that can be easily identified on both images. The user marks these locations by placing pairs of 

vector regions of interest (VROIs) at the matching locations of the target and source images. The source 

image is then transformed to match the coordinates of its landmarks with the landmark coordinates of 

the target image. 

Steps: 

1) Open source image in one document window.  

2) Open target image in another document window (Fig. 9).  

3) Place the same number (at least three) of matching vector ROIs (VROIs) over easily identifiable 

locations (landmarks) on the source image and the target images (Fig. 11).  

a. Use Vector > Construct Vector ROI or the toolbar tool  to draw VROIs.  

Fig. 9. Source (left, ultrasound) and target (right, MRI) images of the prostate for 
cross-modality coregistration with landmarks. 
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b. Open Vector ROI Properties dialog by double-clicking on the VROI (Fig. 10). For each 

location, enter a unique VROI name into the name text field.  

 

4) Check that the landmarks on the source and target images match. Activate the source image, 

then select Vector > List All Vector ROIs. A dialog with all VROIs in the source document window 

will be displayed (Fig. 12). Note the list of VROIs (or take a screenshot). Then activate the target 

Fig. 11. Source and target images with 3 VROIs (green rectangles) on each image. 

Fig. 10. Vector ROI Properties dialog for the active VROI on MRI (with circles over 
corners) with VROI name defined as ‘anterior’. The matching VROI on the 
ultrasound image (next to the letter A) has the same name. 

Fig. 12. Vector > List All Vector ROIs displays a list of 
all VROIs in the document. 
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window and again display the list of VROIs. The two sets must contain identical sets of VROIs, 

with matching numbers and names (the order of VROIs does not matter).  

5) Activate the target image. Select Register > Landmark Registration. This will open a dialog 

(Register Volumes using Landmarks, Fig. 13) to adjust the parameters. Select the interpolation 

type best suited for the imaging modality. To save this transformation for the future, click 

Browse next to the Transformation File text field. This will open browse-for-file to specify the 

location and name of the volume transform file (*.vtf).  

6) If mistakes were found in defining landmarks (e.g., mismatched number of VROIs), an error 

message will be shown. Check the number and names of the VROIs and repeat coregistration.  

7) Click OK. If no gross mistakes were found in defining the landmarks, image processing dialog will 

be displayed (Fig. 14) with the basic measures for each VROI, the transformation matrix, and 

root mean square error (RMSE). If the distances and errors are acceptable, click Yes to proceed 

with the coregistration. Large distances and errors may signal that landmarks were mislabeled. 

Fig. 13. Register > Landmark Registration opens dialog 
to adjust the parameters and save the transformation 
file (optional).  

Fig. 14. Image processing dialog shown if no 
gross errors in landmarking were found. The 
dialog shows distances between landmarks 
and the transformation matrix.  
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In this case click No to cancel the operation, correct the VROI labels and repeat the 

coregistration operation.  

8) If the user clicks Yes, the coregistered image will be created and added as a new layer in the 

target document window (Fig. 15). If transformation was saved as *.vtf, this file will be created 

at the specified location. 

9) Use Layer Control > Alpha and ViewFilter to check the accuracy of coregistration. To improve 

landmark registration, use more advanced transformation and adjust the parameters on the 

Register Volumes using Landmarks dialog).  

 

Fig. 15. Result of landmark registration. Target image (right, MRI) has a new layer 
(named prost_US_reg) with coregistered ultrasound image.  


