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Vector Regions of Interest (VROIs) 
 

 Introduction 
Vector regions of interest (VROIs) are rectangular regions in 2D, 3D, or 4D. VROIs are defined by the 

coordinates of their corners in contrast to raster ROIs, which are defined as arrays of pixel values.  

VROIs are used for annotating subsets of the document, cropping images, measuring distances, placing 

anatomical landmarks, and as seeds required by several commands (such as Connected Component by 

Seed, EdgeWave segmentation, and Image-Derived Input Function). 

VROIs can be created and manipulated using the commands under the main menu’s Vector tab, which 

becomes available when images are loaded into FireVoxel. VROIs can also be drawn and rasterized with 

the help of the toolbar tools. 

 Display VROIs and List all VROIs 
VROIs are shown as semi-transparent rectangles, with sides parallel to the 

(X,Y,Z) axes of the document (Figure 1). The two intersecting diagonals 

indicate the VROI center. The size of a VROI may be smaller than a single 

voxel. As a result, a VROI may be nearly invisible. 

The visibility of all vector entities (VROIs, polylines, and contours) 

in a document is toggled on and off using View > Display\Hide Vector.  

A list of all VROIs in the active document can be displayed using Vector > 

List all Vector ROIs, which opens a dialog (List of all VROIs) showing the total 

number of VROIs followed by a list of VROI names and the intervals of 

dynamic indices on which each VROI is defined.  

 Construct VROI  
Load images into FireVoxel using File > Open DICOM folder: Single Document or open a previously 

saved FireVoxel document (File > Open FireVoxel Document). The images will be displayed in 

a document window and can be viewed in the Slice view or the Film view (double-right-click to toggle 

between these views). VROIs can be drawn on either the Slice or the Film view. However, a VROI is 

initially defined only on a single slice (2D) and only on the current dynamic frame in a 4D dataset. 

To select a slice, press Up and Down arrow keyboard keys; to select a dynamic frame in a 4D document, 

use Right and Left arrow keys.  

Select Vector > Construct Vector ROI (or click Construct vector ROI toolbar icon). The cursor will 

become a cross. Move this cross to the location where the lower left corner of the VROI should be and 

left-click (the mouse button does not need to be held down after the click). A pair of small green circles 

(handles) will appear at the location of the mouse click. Move the cursor towards the upper right corner 

of the VROI. The VROI will be shown as a semi-transparent green rectangle with the corners at the initial 

Figure 1. VROI (green box) 
enclosing the left kidney on 
DCE MRI.   
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mouse click and the current cursor position. Click again to complete the VROI. The cursor will revert to 

the standard white arrow. To exit from the VROI tool without drawing a VROI, press Esc. The dimensions 

and position of the VROI can be easily adjusted, therefore it is not necessary to draw VROIs precisely on 

the first attempt. 

 Matching VROI coordinates to voxel indices 
A VROI is defined by the coordinates of its handles: the lower 

left corner (X0, Y0, Z0) and upper right corner (X1, Y1, Z1). 

The VROI coordinates and dimensions are specified as real 

(decimal) numbers. These real-valued coordinates need to be 

mapped onto integer voxel indices (0, 1, 2,…). In FireVoxel, 

voxel i contains points with coordinates that lie in a semi-open 

interval [i, i +1) (closed on the left, open on the right). 

Therefore, voxel 0 extends over the coordinates [0.0, 1.0): 

coordinate 0.0 is part of the first voxel, whereas the point with 

coordinate 1.0 is part of the second voxel (Figure 2). This 

convention holds for each of the (X,Y,Z) axes. 

A VROI also has a dynamic index (4th dimension coordinate). 

The dynamic index takes integer values in the interval [t0, t1], where t0 and t1 are the first and last 

indices of the dynamic frames on which the VROI is defined.  

 Activate, resize, and move a VROI 
A VROI has two states, active and inactive. An active VROI can be manipulated (moved, resized, 

rasterized, etc.). An active VROI shows handles  small circles in the lower left and upper right corners. 

Inactive VROIs do not have these handles. Only one VROI in the document can be active at a time. 

To activate a VROI, click anywhere inside this VROI. To inactivate a VROI, click anywhere outside the 

active VROI. 

To resize a VROI, activate it, left-click either of its handles (the cursor will become a cross) and drag it to 

increase or decrease the size of the VROI. 

To move a VROI without changing its dimensions, right-click and hold an active VROI (the cursor will 

change to four white arrows) and drag it to a new location; release the right mouse button to finish. 

A 2D VROI can be manually converted into a 3D VROI by displaying the image in orthogonal projections 

(click Display Orthogonal Projections toolbar icon) and resizing the VROI to extend across several 

slices. Alternatively, this can be done using Vector > Vector ROI 2D -> 3D. 

The dimensions, position, and other features of VROIs may also be configured using the Vector ROI 

Properties panel. 

Figure 2. VROI (green rectangle), its 
coordinates (X0 and X1), and voxels (gray 
squares labeled 0, 1, 2). 
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 Vector ROI Properties 
VROIs can be adjusted and manipulated via 

the Vector ROI Properties panel (Figure 3). 

To open it, double left-click on the VROI. 

A common mistake is to double right-click, 

which switches the document from the Slice 

view to the Film view. To recover from this 

mistake, navigate to the VROI and double 

right-click again to switch back to the Slice 

view.  

The properties panel can remain open while 

the user activates different VROIs, uses Vector > Next Vector ROI (F11) function, or even deletes all 

VROIs. The Vector ROI Properties panel has the following fields.  

Name – VROI name. By default, VROIs are named vroi_N (N=0, 1, 2,…) and numbered in the order in 

which they are created in the document. Custom VROI names may be entered into the name box. 

Renaming will not affect their original order, which is used, e.g., by Vector > Next VROI (F11) command. 

Color – The color swatch showing the current color (green by default). Double-click to open the standard 

Windows color picker and select custom color. The color may be changed only for already existing 

VROIs. 

Coordinates – The real-valued coordinates of the lower left and upper right corners, (X0, Y0, Z0) and (X1, 

Y1, Z1), respectively. By default, the units are voxels, but may be switched to millimeters by using the 

dropdown menu labeled units (in the lower right corner) and selecting mm instead. The coordinates are 

recomputed when VROI is moved or resized manually. Typing over the current values will change the 

position and dimensions of the VROI. After typing a number in a text box, click on another text box or 

press Tab for the change to take effect. Pressing Enter would close the properties panel.  

Dimensions – Width, Height, and Depth (in horizontal, vertical, and slice directions) of the VROI. Typing 

new values into these boxes will change the size of the VROI. The coordinates will be recomputed 

accordingly. To extend a VROI over several slices, enter a number greater than 1 into the Depth box. 

The correct placement of the VROI may be verified by displaying the image in the Film view.  

Center – Coordinates of the VROI center, defined by the intersection of the diagonals. 

Units – Drop-down menu to select the units of Coordinates, Dimensions and Center (voxels (default) or 

millimeters).  

Dynamic index interval (Start and End) – Dynamic indices of the first and last dynamic frames between 

which VROI is extended. By default, in a 4D dataset, VROI is defined only on the current dynamic frame. 

Type new values into the boxes to define a custom interval. Scroll through dynamic variable (using right 

and left arrow keyboard keys) to ensure that the VROI has been extended correctly. 

Figure 3. Vector ROI Properties dialog. Note the Depth of 0.9999 
voxels, which corresponds to a single slice. 
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All Timepoints – Clicking this button extends the VROI across all dynamic frames in a 4D dataset (for any 

dynamic variable, including time, b-value, flip angle, inversion time, etc.) 

Center, Full Volume, Scale Dimensions – Functions for quick positioning or scaling. Center moves 

the VROI so that its center coincides with the center of the image. Full Volume extends the VROI to 

the entire image volume on all slices of the current dynamic frame (use Dynamic index interval settings 

to extend to other frames). Scale Dimensions opens a dialog to enter a scaling factor by which all three 

VROI dimensions will be multiplied after the user clicks OK (default, 1, no scaling). Scaling resizes the 

VROI, but does not change the in-plane coordinates of its center.  

 Next VROI (F11) 
Vector > Next Vector ROI (F11) is used to activate the next VROI (in the order they were created) and 

display the slice containing its center (note that voxel coordinates, including slice numbers, start from 

zero). If the document is in the Film view, the command switches it to the Slice view. If the active VROI is 

the last one in the document, the command circles back to the first VROI. This command is convenient 

when multiple, overlapping VROIs are present in the document.  

 Save VROIs 
The easiest way to save VROIs is to save them together with the FireVoxel document in which they are 

defined using File > Save FireVoxel Document.  

VROIs can also be exported as a separate file using Vector > Save Vector ROIs. This opens a file-save 

dialog to select the directory and name of the target file, which is given a .vroi extension. This file can be 

opened using a text editor, such as Notepad. The .vroi file contains the total number of ROIs followed by 

each VROI’s defining properties (ROI label, Windows color code, T0 and T1 dynamic indices, X0, X1, Y0, 

Y1, Z0, Z1 coordinates).  

 Load VROIs 
Previously saved VROIs can be loaded into the document using Vector > Load Vector ROIs. This opens 

a browse-for-file dialog to select a .vroi file. Once the user selects this file, the VROIs are recreated in the 

document and displayed. If these imported VROis are then modified (resized, repositioned, etc.), they 

need to be saved again, either with the document or as a .vroi file. 

 VROI-based operations 
VROIs may be used for a variety of purposes, as illustrated by the following examples. 

10.1 Seed VROI 
Several commands, such as ROI > Connected Component by Seed, Segment > EdgeWave (Basic, Live 

Single Seed, etc.), Dynamic Analysis > Image-Derived Input Function and others, require a seed VROI 

that needs be created prior to the use of the command. The seed VROI may be de defined manually, as 

described above, or in some cases automatically. For example, for brain segmentation on MRI, the seed 

VROI may be generated using Workflows > Brain-MR > Find White Matter Seed.  
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10.2 Crop 
VROIs can be used to select the relevant part of an image and discard the rest of data. To crop, define 

and activate a VROI and select Volume > Crop > Crop with 4D Vector ROI (Active Layer only or All 

Layers). These commands create a new document window displaying only the part of the original image 

enclosed by the active VROI. If the original document contains two or more VROIs, an error message 

is shown prompting the user to select (activate) one of the VROIs. 

10.3 Rasterize 
A VROI can be rasterized, or used to create a raster ROI covering the area enclosed by the VROI. 

Vector > Rasterize selected vector entities rasterizes the active VROI. The same operation can be 

performed by clicking Rasterize  toolbar icon. Rasterize All VROIs rasterizes all VROIs in the 

document. 

The results of the Rasterize commands are added to the active ROI layer. Open the Layer Control panel 

(by double left-clicking on the image) to view the document layers. If the active layer is not an ROI layer, 

a new ROI layer is created automatically, and rasterized areas are added to this new layer. To add 

the rasterized area to a specific ROI layer, activate this layer first by clicking on its name in the Layer 

Control, and then apply the Rasterize command.  

10.4 Measure distances and angles 
VROIs may be convenient for estimating distances and angles in the 

image. The distances along the (X, Y, Z) directions can be obtained 

directly from the dimensions of the VROI. The distances in arbitrary 

directions may be measured by drawing a VROI with the diagonal 

aligned with the direction of interest and computing the length of the 

diagonal. The angles may be estimated in a similar fashion. For example, 

VROIs are useful for measuring the angles between a given direction in 

the image and the image’s (X, Y, Z) axes (Fig. 4). In this case, 

trigonometric functions of the angle in question can be estimated from 

the width and height of the VROI.  

The VROI may also serve as a template for alignment of a polyline 

(a vector object made up of control points and connecting segments). 

A polyline may be drawn using Vector > Insert polyline or   toolbar 

icon. A single-segment (two-point) polyline can be used for measuring 

distances and a two-segment (three-point) polyline can be used for 

measuring angles. To display the length or angle measure next to the polyline, make sure that 

View\Hide > Display Curve Length is toggled on. 

 

Figure 4. A VROI may be used to 
estimate the misalignment of the 
brain medial axis with the Y axis of 
the image.  


