5. Interface and User Actions

FireVoxel’s graphical user interface (GUI) allows user to access commands and tools. This chapter describes the GUI elements and typical user actions. The appearance and functionality of GUI can be adjusted using File > User Interface Options.

5.1. Mouse and keyboard actions

The mouse and keyboard actions described below are employed to interact with FireVoxel’s user interface. Note that these actions refer only to a typical two-button Windows-based mouse, as FireVoxel is a Windows software.

Click – Single left mouse click, unless specified otherwise. Used to open menus and select commands or launch commands via toolbar icons.

Double-click – Double-left mouse click.

Right-click and double-right click – Right mouse click, single or double.

Scroll - Turn the mouse up or down. May be used for, e.g., navigating through the slices of a 3D or 4D image.

Click and drag – Left-click and hold down the left mouse button and move the mouse. Used, e.g., to draw vector ROIs and move anchor points on a vector contours.

Right-click and drag – Click and hold down the right mouse button and move the mouse. Used, e.g., to move a vector contour as a whole.

FireVoxel's interface without images

Fig. 5.1 FireVoxel’s interface without images.

Hover – Hold the cursor over an object.

Ctrl + left mouse – Press and hold down Control key while pressing the left mouse button and moving the mouse. Used to draw voxel-based ROIs (section X).

Ctrl + right mouse – Press and hold down Control key while pressing the right mouse button and moving the mouse. Used to erase voxel-based ROIs (section X).

Up and Down arrow keys - Pressing the Up and Down arrow keys on the keyboard is used to navigate through slices of a 3D or 4D image (similar to Scroll).

Right and Left arrow keys - Pressing the Right and Left arrow keys on the keyboard is used to navigate through the images along the dynamic dimension of a 4D (dynamic) dataset, such as the different time points in dynamic contrast-enhanced MRI or CT, or b-values in diffusion-weighted MRI.

Esc - Esc key is used to exit various tools, such as the MagTrace tool and most of the toolbar tools.

5.2. Open FireVoxel

To open FireVoxel, double-click FireVoxel.exe in FireVoxel directory. User can also create a desktop shortcut and double-click it to launch FireVoxel.

5.3. Main software window and document windows

Launching FireVoxel opens the main software window (Fig. 5.1). It contains the main menu (at the top), status bar (at the bottom), main toolbar (on the right, inactive until images are loaded), and minimize/maximize/close buttons.

With images, the main toolbar becomes operational. Images are displayed in document windows. Each document window is labeled with a name in the blue title bar and minimize/maximize/close buttons. The images are aligned left, and extra space is filled with solid color. More than one document window may be opened at once.

FireVoxel's interface with an image open

Fig. 5.2 FireVoxel’s interface with an image loaded.

5.5. User Interface Options

FireVoxel’s graphical interface can be customized using File > User Interface Options. This command opens a panel where the user can adjust parameters controlling the appearance and functionality of the interface (Fig. 5.3).

User Interface Options panel

Fig. 5.3 User Interface Options panel.

5.5.1. Temp folder

Shows the current location and size of FireVoxel’s Temp folder. The user can type in a path to a different folder or browse to folder to select it. Clear button deletes the contents of the Temp folder. The location of the Temp folder is also shown in Help > Display current UI configuration.

5.5.2. Interface color scheme

Offers a dropdown menu with a selection of color schemes: Basic (default), Aqua, Luna Blue, Obsidian, Silver. The schemes alter the color of the main software window, main toolbar, and bottom information bar. Changes are applied immediately.

5.5.3. Document background

Opens a color picker for selecting the padding color of the document windows (the color that fills parts of the window not occupied by the image). The default color in the basic color scheme is moderate blue HEX 6060c0 (RGB [38, 38, 75], RGB decimal [96, 96, 192], CMYK [50, 50, 0, 25], Hue/Sat/Lum 160/104/136).

5.5.4. Main toolbar alignment

Opens a dropdown menu with a selection of positions where the main toolbar is docked: Left, Top, Right (default), Bottom. The change of position is applied immediately. If a toolbar is undocked and then docked again, it is docked at the position specified by this option.

5.5.5. Display

5.5.5.1. Initial layout

Opens a dropdown menu with options for the initial layout: FilmView (default), Single Slice, and Axial, Sagittal, and Coronal projections. The option is applied upon the next loading of images into FireVoxel. The option does not affect previously saved FireVoxel documents, which are opened in the saved view.

5.5.5.2. View Convention

Opens a dropdown menu with options for image orientation: Radiological (axial images are shown with patient’s left side on the right side of the image); Neurological (left side on the left); or Original Data (orientation follows the convention of the original data).

Images in NIfTI-1 format with sform and qform entries are displayed as prescribed by their header entries. Images in NIfTI-2 format are not compatible with FireVoxel.

5.5.5.3. Use Interpolation

Checkboxes for selecting the types of layers and views shown with interpolation. Options include Volumes (checked by default), ROIs (unchecked), Real-valued volumes (checked), and Film View (unchecked). Interpolation makes images appear less grainy.

5.5.5.4. Patient Orientation

Checkbox (checked by default) toggling the visibility of green letters indicating patient orientation: R (right), L (left), A (anterior), P (posterior), H (head), F (feet).

5.5.6. Volumetric Cursor

Opens a dropdown menu with options for the cursor behavior when three orthogonal projections are shown (see Display orthogonal projections). If Multiprojection Synchronize on left mouse click is selected (default), left mouse click on any of the three projections forces the other two views to display the current cursor position on each of these projections; on each projection, the cursor is shown as a cross indicating the intersection of the remaining two imaging planes. Regular cursor allows the three projections to be displayed independently, without sensitivity to mouse clicks.

5.5.7. Automatically tile all views when a document is loaded

Checkbox (checked by default) controlling the arrangement of document windows. When checked, has the effect of View > Tile after a new document is loaded.

5.5.8. Specify missing modality when loading volumes

Checkbox (checked by default). ADD DETAILS

5.5.9. Load Dynamic Modelling settings from FVX file

Checkbox (checked by default) for toggling loading of dynamic modeling parameters from the saved .fvx document. ADD DETAILS

5.5.10. Default volume transform interpolation

Opens a dropdown menu with options for interpolation methods: Nearest neighbor, Tri linear (default), Wsinc2, Wsinc3, Wsinc4. The interpolation method may be chosen to best suit the imaging modality at hand (e.g., Tri linear for CT or Wsinc for MRI).

5.5.11. Compression

5.5.11.1. Losslessly Compress DICOM file when saving (JpegLS)

Checkbox (unchecked by default) to apply compression to DICOM files upon saving. ADD DETAILS

5.5.11.2. RAM Compress Integer volumes

Checkbox (checked by default) to compress RAM compression to integer volumes. ADD DETAILS

5.5.11.3. RAM Compress Real volumes

Checkbox (unchecked by default) to compress RAM compression to real volumes. ADD DETAILS

5.6. Commands, parameter panels, and dialog

FireVoxel commands may be executed directly or they may open dialog prompting the user to configure the command by selecting the parameters or options. Some commands may launch browse-for-file, browse-for-folder, or file-save dialogs.

Commands labeled Copy to Clipboard copy information (usually from an output dialog) and allow the user to paste it to a text file, spreadsheet, or other software.

5.7. Close FireVoxel

To close FireVoxel, select File > Exit. If any open documents contain unsaved changes, a file save dialog will be shown to prompt the user to save these documents, discard changes, or cancel exiting. The sofware will be closed afterwards.

The software can also be closed by clicking the cross in the upper right corner of the main software window. Again, the user will be prompted to save or discard any new changes to the currently open documents, after which the software will be closed.