10. View

The View tab on the main menu contains commands for adjusting how documents and images are displayed in FireVoxel. Some of these commands are also accessible through the Toolbar.

These tools do not alter the images, but only change how they are shown. Customized views can be saved as FireVoxel documents.

Additional tools for adjusting the appearance of layers (such as the layer order, visibility, ROI color, and color map options) are available through Layer Control.

10.1. Interface configuration (View)

10.1.1. New view

Creates a copy of the active document window in a new window. The original window is renamed [name]:1 and the new window is named [name]:2, etc. Each view can be manipulated independently and saved separately.

10.1.2. Cascade

Arranges all document windows as a stack (cascade), with the active window in front.

10.1.3. Tile

Arranges all document windows as tiles. Minimized windows are not tiled and remain minimized.

10.1.4. Show Main Toolbar

Toggles on/off the visibility of the toolbar. Checked by default (toolbar visible).

10.1.5. Select All

Selects all vector entities (vector ROIs and polylines) in the active document. With all vector entities selected, clicking anywhere outside the vectors deselects all. Clicking any vector entity selects that entity and deselects the others. Verify

10.1.6. Close

10.1.6.1. Close Document

Closes the active document. CAUTION: This command does not have a file save dialogue, so any previously unsaved changes may be lost. To avoid losing unsaved work, close documents by clicking the red rectangle with a white x in the upper right corner, which has a file save dialogue.

10.1.6.2. Close All Documents

Closes all documents. CAUTION: No file save dialogue.

10.1.6.3. Close All Documents but this

Closes all documents except the active one. CAUTION: No file save dialogue.

10.1.6.4. Close All Views but this

Closes all views of the images displayed in the active window (usually orthogonal projections) except the active window.

10.2. Orthogonal Projections

Specify Volume Projection panel

Fig. 10.1 Specify Volume Projection panel.

10.2.1. Set projection for this view (View & Toolbar)

Opens a dialog panel (Specify Volume Projection, Fig. 10.1) to configure orthogonal projection for the current document window. Clicking View Projection icon set_project opens the same panel.

The top part (Rotation) contains boxes to enter angles (in degrees) of rotation about X, Y, and Z axes. Orthogonal rotations can be applied by clicking buttons +/-90 (degrees) (Fig. 10.2, Fig. 10.3, Fig. 10.4).

Projection at 90 deg about Z axis

Fig. 10.2 Projection at 90 deg about Z axis.

Projection at 90 deg about X axis

Fig. 10.3 Projection at 90 deg about X axis.

Projection at angles about X, Y, Z axes

Fig. 10.4 Projection at angles about X, Y, Z axes.

Clicking Original restores the original orientation. The Type dropdown menu offers the choice of several types of views: Normal (regular rotation, default), Max Intensity (maximum intensity projection), Max Intensity with Zero block, Min Intensity (minimum intensity projection), Slab Average (each voxel contains average signal at that location over the entire slab). ADD DETAILS

10.2.2. Reset projection for this view (View)

Restore the original view for the current document window.

10.2.3. Max intensity projection snapshot (View)

Opens a new document window (named snapshot) with the maximum intensity projection (Fig. 10.5).

The snapshot has the same in-plane dimensions as the original image, but contains only a single slice.

The snapshot cannot be converted back into the original image. In contrast, maximum intensity image obtained using Set projection with Type > Max intensity can be reset to the original image by selecting Type > Normal.

MR Angiography max intensity projection snapshot

Fig. 10.5 MR angiography axial and coronal views (left and center, respectively) and coronal maximum intensity projection snapshot (right).

10.2.4. Display orthogonal projections (Toolbar)

Clicking Display orthogonal projections icon orthog_project opens document windows with orthogonal projections complementary to the view in the active document window. For example, for an axial view, the command opens coronal and sagittal views. By default, the new windows are tiled.

The windows opened depends on the setting in File > User Interface Options > Loading > Left Side on Right. If this option is checked, and the images are displayed in the traditional radiological orientation (left side on the right), Display orthogonal projections opens two additional windows (for a total of three orthogonal projections, including the original). If the option is unchecked, Display orthogonal projections opens three additional windows: the orthogonal projections plus the original projection in left-side-on-the-left orientation (for a total of four projections, including the original).

If the user clicks Display orthogonal projections icon two or more times (with the same or different windows activated), no new windows are opened besides the original set, although document windows may be re-tiled after each icon click.

10.3. Zoom

10.3.1. Zoom By Window (View & Toolbar)

Zoom in on a rectangular selection with a mouse. To launch the tool, select View > Zoom by window or click zoom_by_window icon (cursor becomes a magnifying glass). To use, click the image, drag the mouse to expand a white dashed rectangle and release the mouse button. Tool quits upon mouse release. To undo and return to the original view, use View > Zoom All.

10.3.2. Zoom in/out with fixed upper left corner (View & Toolbar)

Zoom whole image relative to the upper left corner. To apply, select View > Zoom in or Zoom out or click icons zoom_in or zoom_out. Repeat until a desired zoom level is reached.

10.3.3. Zoom All and fit to View (View & Toolbar)

Restore original view (undo zoom in or out). To apply, select View > Zoom All or clicking Zoom All toolbar icon zoom_all.

10.3.4. Zoom 1x1 (View)

Display each image voxel as one pixel on screen. Use Zoom All to return to the original view.

10.4. Display graphics (View)

10.4.1. Display/Hide vector

Toggles on/off (checked/unchecked) visibility of vector ROIs and polylines in the active document window (or current view if several orthogonal projections are open).

10.4.2. Display/Hide raster

Toggles on/off visibility of image layers and raster ROI layers in the active document window (or current view if several orthogonal projections are open).

10.4.3. Display/Hide grid

Toggles on/off visibility of a rectangular grid. Opens dialog (Specify Grid Step) with a box for entering the Grid Step in millimeters. Displays a square grid of green lines spaced by grid step in row and column dimensions. The grid is shown for all slices, but only for the current view (if orthogonal projections are displayed). To change the grid step, use this command twice and enter a new grid step.

Display curve length

Fig. 10.6 Display curve length.

10.4.4. Display/Hide Curve Length

Toggles on/off visibility of the length of a polyline. The length (in millimeters) is displayed next to the polyline as a red number (Fig. 10.6).

10.4.5. Enumerate polylines

Toggles on/off the visibility of the numbers labeling control points in polylines and MagTrace splines (Fig. 10.7).

The numbers are shown as red numbers next to each control point. The numbers remain visible for both active and inactive polylines.

Enumerate polylines

Fig. 10.7 Enumerate polylines option ON.

10.4.6. Contour and Fill Properties

Opens a panel (Polyline and Spline properties) for adjusting parameters of vector polylines and splines. This panel can also be open by double-clicking a polyline or spline. This panel is described in detail in Trace section on Magnetic Trace tool.

10.5. Dynamic experiment (Toolbar)

10.5.1. Play 4D experiment (Toolbar)

Clicking Play 4D experiment icon play_4d_exp_icon to display the dynamic frames of the current slice consecutively for a user-specified time interval. Opens dialog (Specify Interframe time delay (.001 sec precision)) with a box for entering the time during which each frame is shown. Clicking OK starts the sequence of views. The cursor turns into a blue wheel.

10.5.2. Display voxel TAC (Toolbar)

Clicking Display voxel TAC icon voxel_tac_icon opens a panel to view the time-activity curve (TAC) at the current voxel (Dynamic Activity Curve: Signal values, Fig. 10.8).

Display voxel time-activity curve panel

Fig. 10.8 Display voxel TAC panel.

The panel shows the TAC plot, with the origin and maximum values of the horizontal and vertical axes.

Options:

Attributes – Opens dialog to enter T1 value for conversion to concentration.

Concentration – Opens panel (Concentration Conversion) for converting MRI signal intensity to gadolinium concentration.

Radius (voxels) – Up and down arrow buttons for adjusting the size of the sampled area. Default size, 0 (1 voxel).

2D (checkbox) – Checked by default, toggles between 2D and 3D sampling mode.

Save – Opens browse for file dialog for saving the current TAC as a text file with two columns: dynamic dimension and signal.